查看: 300|回复: 8|关注: 0

[已解决] mex

[复制链接]

新手

15 麦片

财富积分


050


13

主题

42

帖子

0

最佳答案
>> mex -setup
错误使用 mex
未找到支持的编译器或 SDK。有关选项,请访问  http://www.mathworks.com/support/compilers/R2014a/win64

请教各位,这种情况怎么解决,我安装了tdm64-gcc-5.1.0-2,并且配置了环境变量,也还是这种情况。

132.png

论坛优秀回答者

18

主题

1988

帖子

420

最佳答案
  • 关注者: 81
发表于 2019-7-9 10:28:15 | 显示全部楼层
哪个版本的matlab?
多看帮助文档
说明你的matlab版本

新手

15 麦片

财富积分


050


13

主题

42

帖子

0

最佳答案
 楼主| 发表于 2019-7-9 11:13:42 | 显示全部楼层
深蓝孩童 发表于 2019-7-9 10:28
哪个版本的matlab?

MATLAB R2014a

论坛优秀回答者

18

主题

1988

帖子

420

最佳答案
  • 关注者: 81
发表于 2019-7-9 11:27:27 | 显示全部楼层

2014a没有正式支持MinGW-w64 参考 https://stackoverflow.com/questions/8552580/using-gcc-mingw-as-matlabs-mex-compiler
多看帮助文档
说明你的matlab版本

新手

15 麦片

财富积分


050


13

主题

42

帖子

0

最佳答案
 楼主| 发表于 2019-7-9 15:56:10 | 显示全部楼层
深蓝孩童 发表于 2019-7-9 11:27
2014a没有正式支持MinGW-w64 参考 https://stackoverflow.com/questions/8552580/using-gcc-mingw-as-mat ...

我重新安装个2018新版本,编译器应该安装tdm64-gcc-5.1.0-2还是MinGW-w64呢

论坛优秀回答者

18

主题

1988

帖子

420

最佳答案
  • 关注者: 81
发表于 2019-7-9 16:40:21 | 显示全部楼层
asce 发表于 2019-7-9 15:56
我重新安装个2018新版本,编译器应该安装tdm64-gcc-5.1.0-2还是MinGW-w64呢

看支持的编译器版本。18a使用MinGW 5.3,16b使用MinGW 6.3。或者使用vs 2017
多看帮助文档
说明你的matlab版本

新手

15 麦片

财富积分


050


13

主题

42

帖子

0

最佳答案
 楼主| 发表于 2019-7-9 20:38:50 | 显示全部楼层
深蓝孩童 发表于 2019-7-9 16:40
看支持的编译器版本。18a使用MinGW 5.3,16b使用MinGW 6.3。或者使用vs 2017

我安装完了2018a和MinGW 5.3,而且也配置了环境,可是还是不行。。麻烦再指导一下。。
123.png

论坛优秀回答者

18

主题

1988

帖子

420

最佳答案
  • 关注者: 81
发表于 2019-7-9 21:01:23 | 显示全部楼层 |此回复为最佳答案
asce 发表于 2019-7-9 20:38
我安装完了2018a和MinGW 5.3,而且也配置了环境,可是还是不行。。麻烦再指导一下。。
...

https://www.mathworks.com/matlab ... to-work-with-matlab

好像帮助文档说了不要安装在有空格的地方?有错误百度一下?看看帮助文档?
多看帮助文档
说明你的matlab版本

新手

15 麦片

财富积分


050


13

主题

42

帖子

0

最佳答案
 楼主| 发表于 2019-7-10 11:21:55 | 显示全部楼层
深蓝孩童 发表于 2019-7-9 21:01
https://www.mathworks.com/matlabcentral/answers/313298-i-already-have-mingw-on-my-computer-how-do- ...

多谢解答:handshake
您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐上一条 /3 下一条

快速回复 返回顶部 返回列表